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Before we begin…
You can download ParaView and install on your 
computer

http://www.paraview.org/download/

Launching a VNC session on Maverick:
- From the command line
- From the vis.portal.tacc.utexas.edu
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Data Types
•Supports a wide variety of data types

–Structured grids
•uniform rectilinear, rectilinear, and curvilinear

–Unstructured grids
–Polygonal data

•Time series support
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1.2 Basics of Visualization

Put simply, the process of visualization is taking raw data and converting
it to a form that is viewable and understandable to humans. This allows us
to get a better cognitive understanding of our data. Scientific visualization
is specifically concerned with the type of data that has a well defined repre-
sentation in 2D or 3D space. Data that comes from simulation meshes and
scanner data is well suited for this type of analysis.

There are three basic steps to visualizing your data: reading, filtering,
and rendering. First, your data must be read into ParaView. Next, you may
apply any number of filters that process the data to generate, extract, or
derive features from the data. Finally, a viewable image is rendered from the
data.

ParaView was designed primarily to handle data with spatial representa-
tion. Thus the primary data types used in ParaView are meshes.

Uniform Rectilinear (Image Data)
A uniform rectilinear grid is a one- two-
or three- dimensional array of data. The
points are orthonormal to each other and
are spaced regularly along each direction.
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Non-uniform Rectilinear (Rectilinear
Grid)
Similar to the uniform rectilinear grid ex-
cept that the spacing between points may
vary along each axis.

Curvilinear (Structured Grid)
Curvilinear grids have the same topology as
rectilinear grids. However, each point in a
curvilinear grid can be placed at an arbi-
trary coordinate (provided that it does not
result in cells that overlap or self intersect).
Curvilinear grids provide the more compact
memory footprint and implicit topology of
the rectilinear grids, but also allow for much
more variation in the shape of the mesh.

Polygonal (Poly Data)
Polygonal data sets are composed of points,
lines, and 2D polygons. Connections be-
tween cells can be arbitrary or non-existent.
Polygonal data represents the basic render-
ing primitives. Any data must be converted
to polygonal data before being rendered
(unless volume rendering is employed), al-
though ParaView will automatically make
this conversion.
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Unstructured Grid
Unstructured data sets are composed of
points, lines, 2D polygons, 3D tetrahedra,
and nonlinear cells. They are similar to
polygonal data except that they can also
represent 3D tetrahedra and nonlinear cells,
which cannot be directly rendered.

In addition to these basic data types, ParaView also supports multi-
block data. A basic multi-block data set is created whenever data sets
are grouped together or whenever a file containing multiple blocks is read.
ParaView also has some special data types for representing Hierarchical
Adaptive Mesh Refinement (AMR), Hierarchical Uniform AMR,
Octree, Tablular, and Graph type data sets.

1.3 More Information

There are many places to find more information about ParaView. The Para-
View Users Manual is online and is located at The ParaView User’s Guide.
ParaView also has an online help that can be accessed by simply clicking the

button in the application.
The ParaView web page, www.paraview.org, is also an excellent place

to find more information about ParaView. From there you can find helpful
links to mailing lists, Wiki pages, and frequently asked questions as well as
information about professional support services.



Data Formats
• Supports a wide variety of data formats

• File->Open->Files of Type)

• Users can write data readers to extend support to 
other formats

• Or conversion to the VTK format (or others)
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Convert to vtk example
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Visualization Algorithms
Supports a wide variety of visualization 
algorithms -> Filters

Isosurfaces
Cutting planes
Streamlines
Glyphs
Volume rendering
Clipping
Height maps
…
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Special Features
• Supports derived variables

• New scalar / vector variables that are functions of existing 
variables in your data set

• Scriptable via Python

• Saves animations

• Can run in parallel / distributed mode for large data 
visualization
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ParaView Visualization Pipeline
All processing operations (filters) produce data sets

Can further process the result of every operation to build 
complex visualizations

e.g. can extract a cutting plane, and apply glyphs (i.e. vector 
arrows) to the result

Gives a plane of glyphs through your 3D volume
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ParaView
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Toolbars

Pipeline Browser

Object Inspector

3D View



Paraview
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Undo/Redo

Camera Controls

View Controls (undo/redo)

VCR Controls

Common 
Controls

Active Variable 
Controls



ParaView Demo

WRF weather forecast data set
(smallwrf.zip)
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Paraview WRT Demo
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Paraview WRT Demo
WRF weather forecast data set

Rectilinear grid
Multiple scalar and vector variables
Time series

Can show:
Clouds
Wind
Temperature
…
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ParaView WRT 
Demo
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ParaView Lab
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Getting Started
Download example data file 
‘disk_out_ref.ex2’

https://vis.tacc.utexas.edu/training/

Right-click, Save link as…

Open ParaView
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ParaView
Today we will:
• Create isosurfaces for a scalar variable
• Clip and slice the surfaces
• Use glyphs to display a vector field
• Use streamlines to show flow through a vector field
• Add slices to show variable values over a plane
• Create volume rendering 
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ParaView

• Open the file 
disk_out_ref.ex2

• Click File -> Open
• Select disk_out_ref.ex2
• Click OK
• Select ALL variables
• Click blue Apply
• Cylinder outline of dataset 

extent displayed
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ParaView
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ParaView
Manipulate Representation and 
color
• Use the Active Variable 

Controls to change color from 
Solid Color -> Pres

• Use Representation toolbar 
to change representation 
Surface -> Surface 
With Edges 

• Click on DisplayPanel
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ParaView
Manipulate Representation and 
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ParaView
Manipulate Representation and 
color
• Use the Active Variable 
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• Click on DisplayPanel
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Manipulate Representation 
and color
• Review Coloring
• Review 
Representation

• Enable Color Legend by 
clicking on icon in 
toolbar

• Click +Z view button
• Explore dataset with 

mouse
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Manipulate Representation 
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Create isosurfaces
Select Contour in pipeline
In Contour By, select 
Temp

Enter 400
Click Apply
Click the eye icon next to 
disk_out_ref.ex2

Change representation to 
Wireframe
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Extract Surface

• Click Filters -> 
Alphabetical -> 
Extract Surface

• Click Apply
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Extract Surface

• Click Filters -> 
Alphabetical -> 
Extract Surface

• Click Apply

6/23/16 33



Clip Surface
• Click Filters -> 
Common -> Clip

• Show Plane should be 
checked

• Click Y Normal and 
enter -1 in second box 
under Normal

• Click blue Apply
• Unselect Show Plane 
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Clip Surface
• Click Filters -> 
Common -> Clip

• Show Plane should be 
checked

• Click Y Normal and 
enter -1 in second box 
under Normal

• Click blue Apply
• Unselect Show Plane 
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Clip Surface
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Slice Surface
• Click disk_out_ref.ex2 in 

Pipeline Browser
• Click Filters -> Common 

-> Slice

• Click Apply
• Click eye next to 

ExtractSurface1 and
Clip1 to hide clip plot

• Click on Y Normal
• Click Apply
• Change Coloring to Temp
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Slice Surface
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Slice Surface
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Create Streamlines
• Click 
disk_out_ref.ex2 in 
Pipeline Browser

• Click Filters -> 
Common -> 
Stream Tracer

• Click Apply
• Hide Slice
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Create Tubes
• Click StreamTracer1 

in Pipeline Browser
• Click Filters -> 
Alphabetical -> 
Tube

• Click Apply
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Create Glyph of Vector Field
• Click StreamTracer1 in 

Pipeline Browser
• Click Filters -> 

Common -> Glyph

• Select V under Vectors 
box

• Select Cone under Glyph 
Type

• Select Coloring 
Temp

• Click Apply
• Click on Tube1 and 

change to Solid Color
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Create Glyph of Vector Field
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ParaView

Edit Color Map
Click on Glyph in Pipeline 
Browser
Under Display -> 
Coloring -> Edit 

Click Folder Icon
Select BLUE...HSV
Click OK
Click Close



ParaView
Edit Color Map
• Click on Glyph in 

Pipeline Browser
• Under Display -> 

Coloring -> Edit 

• Click Favorites (Folder	
icon	with	a	Heart)

• Select Blue to Red 
Click Close



ParaView
Edit Color Map
Click on Glyph in Pipeline 
Browser
Under Display -> 
Coloring -> Edit 

Click Favorites (Folder icon 
with a Heart)
Select Blue to Red Click 
Close



ParaView
Edit Background Color
Click on View(Render 
View) at bottom of 
Properties panel
Click Color Black



ParaView
Create Volume Rendering
Click disk_out_ref.ex2 in 
Pipeline Browser
Under Representation select 
Volume

Show disk_out_ref.ex2 if 
hidden
Hide Clip1
Properties -> Display -> Edit
Click Choose Preset

Choose Black, Orange, .. 
RGB

Modify Function
Click Close



ParaView
Start and Stop Trace

Click Edit -> Delete All (or 
Save your state before deleting: 
File -> Save State)
Click Tools -> Start 
Trace

Create a contour of 
Temperature (Filters -> 
Common -> Contour)
Click Tools -> Stop Trace



Why:
Preparing large render jobs
Automation. Reproducible views
Often easier and more direct way to interact with the GUI



Python “trace” good way to 
learn
Paraview “ Tools->Python Shell”

“Tools->Start Trace” and “Stop Trace”
in conjunction with 
http://www.paraview.org/ParaView3/Doc/Nightly/www/py-doc/



ParaView
Start and Stop Trace
Click Edit -> Delete All (or 
Save your state before deleting: 
File -> Save State)
Click Tools -> Start 
Trace

Create a contour of 
Temperature (Filters -> 
Common -> Contour)
Click Tools -> Stop Trace
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Paraview quick demo

Tools->Start Trace
File->Open or File->”Load State”
Set up your desired view
Save out an image, move camera, save another image 
etc
Tools->Stop Trace



Paraview quick demo

This is one way to add “keyframes” but could also do it 
programmatically… 

You will see something like this:



Paraview quick demo:
Add something like this and run again:
framecnt=0

cam = GetActiveCamera()

num_runs=100

for i in range(0,num_runs):

frac = float(i)/float(num_runs)

if (frac < 1):

cam.Azimuth(-90.0/(float(num_runs)/5.0))

else:

pass

file = "newcam" + '%03d.jpg' % framecnt

WriteImage(file)

print "saved image: " + file

framecnt += 1



ffmpeg –i newcam%03d.jpg newcam.mpg



Questions?
More tutorials available:

http://www.paraview.org/Wiki/The_ParaView_Tutorial


